Product Manager Outage

Incident Report for Embraer Roblox

Resolved

This incident has been resolved.
Posted Apr 30, 2024 - 00:20 UTC

Investigating

Our product manager is currently offline. Please wait while we resolve this issue. This is not a issue on our end, as it's a issue with parcel. We are currently investigating this issue.
Posted Apr 14, 2024 - 03:33 UTC
This incident affected: Product Manager Bot.