Support Bot Offline

Incident Report for Embraer Roblox

Resolved

This incident has been resolved.
Posted Apr 10, 2024 - 07:35 UTC

Investigating

The support bot is currently offline due to revamps.
Posted Apr 10, 2024 - 04:47 UTC
This incident affected: Support Bot.